summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-08 16:57:21 -0500
committerLeo Famulari <leo@famulari.name>2017-11-08 17:24:01 -0500
commitf44169c2a7e72ee366c75161e5758c322c7a76c5 (patch)
tree13ada1552e7ebf87d511873371741dce8ccee057 /gnu/packages/syncthing.scm
parentc5a4a92f1a796e342b7db4c458f1fdb61ffc8d40 (diff)
downloadpatches-f44169c2a7e72ee366c75161e5758c322c7a76c5.tar
patches-f44169c2a7e72ee366c75161e5758c322c7a76c5.tar.gz
gnu: Add go-github-com-tjfoc-gmsm-sm4.
* gnu/packages/syncthing.scm (go-github-com-tjfoc-gmsm-sm4): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b23339de12..3d8e923ba1 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1840,3 +1840,29 @@ Erasure Coding in Go.")
processor feature detection used by the Go standard libary.")
(home-page "https://github.com/templexxx/cpufeat")
(license bsd-3))))
+
+(define-public go-github-com-tjfoc-gmsm-sm4
+ (let ((commit "0f4904804c0f24f1784e10195a4144fcffa86a85")
+ (revision "0"))
+ (package
+ (name "go-github-com-tjfoc-gmsm-sm4")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tjfoc/gmsm")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k56gx2ky0c5kf4icafd7zr809lliqzx2mn88lb6d52ljfpf77q5"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/tjfoc/gmsm/sm4"
+ #:unpack-path "github.com/tjfoc/gmsm"))
+ (synopsis "SM4 block cipher")
+ (description "This package provides a Go implementation of SM4, a block
+cipher used in the Chinese National Standard for Wireless LAN WAPI (Wired
+Authentication and Privacy Infrastructure).")
+ (home-page "https://github.com/tjfoc/gmsm")
+ (license asl2.0))))