summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 20:20:06 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:21 -0500
commitf07ccbc25605c580439e7618523b06192b083208 (patch)
treeb3c1fc6e7007b95c2b4a3a4886578ca383598168 /gnu/packages/syncthing.scm
parentfa22168b5ced52ccc31046b8e8fcd2aea76e7705 (diff)
downloadpatches-f07ccbc25605c580439e7618523b06192b083208.tar
patches-f07ccbc25605c580439e7618523b06192b083208.tar.gz
gnu: Add go-github-com-prometheus-union.
* gnu/packages/syncthing.scm (go-github-com-prometheus-union): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 1087bcba0b..7029fdc55e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2180,3 +2180,28 @@ instrumenting application code, and one for creating clients that talk to the
Prometheus HTTP API.")
(home-page "https://github.com/prometheus/client_golang")
(license asl2.0))))
+
+(define* (go-github-com-prometheus-union
+ #:optional (packages (list go-github-com-client-golang-prometheus
+ go-github-com-client-golang-prometheus-promhttp)))
+ (package
+ (name "go-github-com-prometheus-union")
+ (version (package-version go-github-com-client-golang-prometheus))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build union))
+ #:builder (begin
+ (use-modules (ice-9 match)
+ (guix build union))
+ (match %build-inputs
+ (((names . directories) ...)
+ (union-build (assoc-ref %outputs "out")
+ directories))))))
+ (inputs (map (lambda (package)
+ (list (package-name package) package))
+ packages))
+ (synopsis "Union of Go Prometheus libraries")
+ (description "This is a union of Go Prometheus libraries")
+ (home-page (package-home-page go-github-com-client-golang-prometheus))
+ (license (package-license go-github-com-client-golang-prometheus))))