summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 19:09:09 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:21 -0500
commit30335a2963919976413336e8cfda0cb5dee5c21f (patch)
tree60c65481c41e9f9ab846fcede6da2d8a2faff6a7 /gnu/packages/syncthing.scm
parent5c8c1511e8ab77545dd3a7fc304cca61fedbc237 (diff)
downloadpatches-30335a2963919976413336e8cfda0cb5dee5c21f.tar
patches-30335a2963919976413336e8cfda0cb5dee5c21f.tar.gz
gnu: Update syncthing to 0.14.44.
* gnu/packages/syncthing.scm (syncthing): Update to 0.14.44. [inputs]: Add go-github-com-prometheus-union and remove go-github-com-edsrzf-mmap-go. [source]: Delete bundled dependencies in a snippet. [arguments]: Remove the 'delete-bundled-source-code' phase.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 8 insertions, 18 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 9d8ef9e328..f5e5bb85be 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Petter <petter@mykolab.ch>
-;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,7 +28,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "0.14.43")
+ (version "0.14.44")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -36,7 +36,11 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "175xkc4i00axxljc5kgkr30lm1s9hfmz0hrzrsl91rpwpbh500mv"))))
+ "0fxq52w1b05928xp0a333rg23fabj0nykgg7v4gz01f3vrxyydi1"))
+ (modules '((guix build utils)))
+ ;; Delete bundled ("vendored") free software source code.
+ (snippet
+ '(delete-file-recursively "vendor"))))
(build-system go-build-system)
;; The primary Syncthing executable goes to "out", while the auxiliary
;; server programs and utility tools go to "utils". This reduces the size
@@ -49,18 +53,6 @@
#:install-source? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'delete-bundled-source-code
- (lambda _
- ;; Keep the bundled cznic libraries. There are some "internal"
- ;; cznic libraries that complicate the use of non-bundled copies.
- (rename-file "src/github.com/syncthing/syncthing/vendor/github.com/cznic"
- "cznic")
- (delete-file-recursively "src/github.com/syncthing/syncthing/vendor")
- (mkdir-p "src/github.com/syncthing/syncthing/vendor/github.com/")
- (rename-file "cznic"
- "src/github.com/syncthing/syncthing/vendor/github.com/cznic")
- #t))
-
(add-before 'build 'increase-test-timeout
(lambda _
(substitute* "src/github.com/syncthing/syncthing/build.go"
@@ -129,11 +121,9 @@
("go-github-com-calmh-xdr" ,go-github-com-calmh-xdr)
("go-github-com-ccding-go-stun"
,go-github-com-ccding-go-stun)
+ ("go-github-com-prometheus-union" ,(go-github-com-prometheus-union))
("go-github-com-chmduquesne-rollinghash-adler32"
,go-github-com-chmduquesne-rollinghash-adler32)
-; ("go-github-com-cznic-ql" ,go-github-com-cznic-ql) ; bundled
- ; Used by bundled ql
- ("go-github-com-edsrzf-mmap-go" ,go-github-com-edsrzf-mmap-go)
("go-github-com-gobwas-glob" ,go-github-com-gobwas-glob)
("go-github-com-gogo-protobuf-union"
,(go-github-com-gogo-protobuf-union))