summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 17:21:40 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:30 -0400
commit7dc89dc6a1e1a66e8306aef218004677382d63fe (patch)
tree6a11e821a32a6e3bb9fe398289afea5a6b9d6931 /gnu/packages/syncthing.scm
parent2f9bbd8e6c49a4c204d05a87710e83d69ad80d1f (diff)
downloadpatches-7dc89dc6a1e1a66e8306aef218004677382d63fe.tar
patches-7dc89dc6a1e1a66e8306aef218004677382d63fe.tar.gz
gnu: Add go-github-com-flynn-archive-go-shlex.
* gnu/packages/syncthing.scm (go-github-com-flynn-archive-go-shlex): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index cc7ebe2fe8..c6b986c9c7 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1183,3 +1183,27 @@ Go language.")
language.")
(home-page "https://gopkg.in/ldap.v2")
(license expat)))
+
+(define-public go-github-com-flynn-archive-go-shlex
+ (let ((commit "3f9db97f856818214da2e1057f8ad84803971cff")
+ (revision "0"))
+ (package
+ (name "go-github-com-flynn-archive-go-shlex")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flynn-archive/go-shlex.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j743lysygkpa2s2gii2xr32j7bxgc15zv4113b0q9jhn676ysia"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/flynn-archive/go-shlex"))
+ (synopsis "Go lexer")
+ (description "Shlex is a simple lexer for go that supports shell-style
+quoting, commenting, and escaping.")
+ (home-page "https://github.com/flynn-archive/go-shlex")
+ (license asl2.0))))