summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-06 15:44:03 -0500
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:27 -0400
commit767579d18bb35b5e25de173182f145b62b6c5536 (patch)
treeb1920871024622208dc3bacc6f97124d19a5aac4 /gnu/packages/syncthing.scm
parentc36177c69873c32b617e12a44e8f084f0dea3a2a (diff)
downloadpatches-767579d18bb35b5e25de173182f145b62b6c5536.tar
patches-767579d18bb35b5e25de173182f145b62b6c5536.tar.gz
gnu: go-github-com-sasha-s-go-deadlock: Update to 0.2.0.
* gnu/packages/syncthing.scm (go-github-com-sasha-s-go-deadlock): Update to 0.2.0.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7e61d5ee89..41b6082182 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -469,30 +469,28 @@ Metrics library.")
(license bsd-2))))
(define-public go-github-com-sasha-s-go-deadlock
- (let ((commit "03d40e5dbd5488667a13b3c2600b2f7c2886f02f")
- (revision "1"))
- (package
- (name "go-github-com-sasha-s-go-deadlock")
- (version (git-version "0.1.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sasha-s/go-deadlock")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13p7b7pakd9k1c2k0fs1hfim3c8mivz679977ai6zb01s4aw7gyg"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/sasha-s/go-deadlock"))
- (propagated-inputs
- `(("go-github-com-petermattis-goid" ,go-github-com-petermattis-goid)))
- (synopsis "Deadlock detection in go")
- (description "This package provides tools for detecting deadlocks at
+ (package
+ (name "go-github-com-sasha-s-go-deadlock")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sasha-s/go-deadlock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13p7b7pakd9k1c2k0fs1hfim3c8mivz679977ai6zb01s4aw7gyg"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/sasha-s/go-deadlock"))
+ (propagated-inputs
+ `(("go-github-com-petermattis-goid" ,go-github-com-petermattis-goid)))
+ (synopsis "Deadlock detection in go")
+ (description "This package provides tools for detecting deadlocks at
run-time in Go.")
- (home-page "https://github.com/sasha-s/go-deadlock")
- (license asl2.0))))
+ (home-page "https://github.com/sasha-s/go-deadlock")
+ (license asl2.0)))
(define-public go-github-com-syndtr-goleveldb
(let ((commit "34011bf325bce385408353a30b101fe5e923eb6e")