summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 20:19:21 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:20 -0500
commitbfbe868d8e2ee9000a0cbe9c32b1c08dea595134 (patch)
treee9ff4cd6d161e90590356ba0149d657ba7f6f5b6 /gnu/packages/syncthing.scm
parent13dca4a56e2e568f879d49fc9d83d55656bcff77 (diff)
downloadpatches-bfbe868d8e2ee9000a0cbe9c32b1c08dea595134.tar
patches-bfbe868d8e2ee9000a0cbe9c32b1c08dea595134.tar.gz
gnu: Add go-github-com-client-golang-prometheus-promhttp.
* gnu/packages/syncthing.scm (go-github-com-client-golang-prometheus-promhttp): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index a8581ec25e..fec8d532ad 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2105,3 +2105,39 @@ Prometheus metrics.")
system, kernel and process metrics from the pseudo-filesystem @file{/proc}.")
(home-page "https://github.com/prometheus/procfs")
(license asl2.0))))
+
+(define-public go-github-com-client-golang-prometheus-promhttp
+ (let ((commit "180b8fdc22b4ea7750bcb43c925277654a1ea2f3")
+ (revision "0"))
+ (package
+ (name "go-github-com-client-golang-prometheus-promhttp")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_golang.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kkfx1j9ka18ydsmdi2cdy3hs39c22b39mbc4laykmj2x93lmbdp"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ; The tests require internet access
+ #:import-path "github.com/prometheus/client_golang/prometheus/promhttp"
+ #:unpack-path "github.com/prometheus/client_golang"))
+ (propagated-inputs
+ `(("go-github-com-beorn7-perks-quantile"
+ ,go-github-com-beorn7-perks-quantile)
+ ("go-github-com-golang-protobuf-proto"
+ ,go-github-com-golang-protobuf-proto)
+ ("go-github-com-prometheus-client-model-go"
+ ,go-github-com-prometheus-client-model-go)
+ ("go-github-com-prometheus-common-expfmt"
+ ,go-github-com-prometheus-common-expfmt)
+ ("go-github-com-prometheus-procfs" ,go-github-com-prometheus-procfs)))
+ (synopsis "HTTP server and client tools for Prometheus")
+ (description "This package @code{promhttp} provides HTTP client and
+server tools for Prometheus metrics.")
+ (home-page "https://github.com/prometheus/client_golang")
+ (license asl2.0))))