summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-06-12 15:14:43 -0400
committerLeo Famulari <leo@famulari.name>2018-07-24 19:07:06 -0400
commit39a57afc42d473517f6e62c2d6a5d3c75eee3e89 (patch)
tree5637dc230dfb21bf6515c80b24f1e9b3cf7ba39e /gnu/packages/syncthing.scm
parent869d9c69f32b140ffc7b11314f411ddc92ee2a9e (diff)
downloadpatches-39a57afc42d473517f6e62c2d6a5d3c75eee3e89.tar
patches-39a57afc42d473517f6e62c2d6a5d3c75eee3e89.tar.gz
gnu: syncthing: Update to 0.14.49.
* gnu/packages/syncthing.scm (syncthing): Update to 0.14.49. [source]: Remove obsolete patch. [inputs]: Remove go-github-com-kardianos-osext. * gnu/packages/patches/syncthing-fix-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c9313e7d94..58e3f02db8 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -30,16 +30,15 @@
(define-public syncthing
(package
(name "syncthing")
- (version "0.14.48")
+ (version "0.14.49")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
"/releases/download/v" version
"/syncthing-source-v" version ".tar.gz"))
- (patches (search-patches "syncthing-fix-crash.patch"))
(sha256
(base32
- "0bxkm5jlj6l4gai23bg0y31brr80r9qllh1rdg29pahjn0c2b4ml"))
+ "06mzzj5iwgqw3yva7azrsqs9zpl84srbamza4gm03grp7v9gf3sj"))
(modules '((guix build utils)))
;; Delete bundled ("vendored") free software source code.
(snippet '(begin
@@ -130,7 +129,6 @@
("go-github-com-golang-groupcache-lru"
,go-github-com-golang-groupcache-lru)
("go-github-com-jackpal-gateway" ,go-github-com-jackpal-gateway)
- ("go-github-com-kardianos-osext" ,go-github-com-kardianos-osext)
("go-github-com-kballard-go-shellquote"
,go-github-com-kballard-go-shellquote)
("go-github-com-lib-pq" ,go-github-com-lib-pq)