summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/syncthing.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
downloadpatches-839167ff9d74fc490b32f6a197591964f73b65e5.tar
patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index ffc90472d8..6577955496 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -65,12 +65,12 @@
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
(with-directory-excursion "src/github.com/syncthing/syncthing"
- (zero? (system* "go" "run" "build.go" "-no-upgrade")))))
+ (invoke "go" "run" "build.go" "-no-upgrade"))))
(replace 'check
(lambda _
(with-directory-excursion "src/github.com/syncthing/syncthing"
- (zero? (system* "go" "run" "build.go" "test")))))
+ (invoke "go" "run" "build.go" "test"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)