summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 12:43:27 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:28 -0400
commit4e9e74be074f6c270e30b4fa8a7f54e5f989358c (patch)
tree8223ca97f68a49c2813dde827890b02ba52a495f /gnu/packages/syncthing.scm
parent0c28ee8cc1e24fd9f5657e9f2b70a25b4342e1b5 (diff)
downloadpatches-4e9e74be074f6c270e30b4fa8a7f54e5f989358c.tar
patches-4e9e74be074f6c270e30b4fa8a7f54e5f989358c.tar.gz
gnu: Add go-github-com-audriusbutkevicius-recli.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-recli): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 74479e7a08..cc7ebe2fe8 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -145,6 +145,33 @@ firewall.")
(home-page "https://github.com/AudriusButkevicius/go-nat-pmp")
(license asl2.0))))
+(define-public go-github-com-audriusbutkevicius-recli
+ (package
+ (name "go-github-com-audriusbutkevicius-recli")
+ (version "0.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AudriusButkevicius/recli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m1xna1kb78pkmr1lfmvvnpk9j7c4x71j3a7c6vj7zpzc4srpsmf"))))
+ (build-system go-build-system)
+ (inputs
+ `(("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+ ("go-github-com-urfave-cli" ,go-github-com-urfave-cli)))
+ (arguments
+ `(#:import-path "github.com/AudriusButkevicius/recli"))
+ (synopsis "Reflection-based CLI generator")
+ (description "For a given struct, @code{recli} builds a set of
+@code{urfave/cli} commands which allows you to modify it from the command line.
+It is useful for generating command line clients for your application
+configuration that is stored in a Go struct.")
+ (home-page "https://github.com/AudriusButkevicius/recli")
+ (license mpl2.0)))
+
(define-public go-github-com-bkaradzic-go-lz4
(let ((commit "7224d8d8f27ef618c0a95f1ae69dbb0488abc33a")
(revision "0"))