summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-06 15:47:17 -0500
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:27 -0400
commitac51900dfdef2e6d293d81a55c80426f27e04705 (patch)
tree93274a47afb6b433bbed1eb0df84b2a6e2f1a509 /gnu/packages/syncthing.scm
parent767579d18bb35b5e25de173182f145b62b6c5536 (diff)
downloadpatches-ac51900dfdef2e6d293d81a55c80426f27e04705.tar
patches-ac51900dfdef2e6d293d81a55c80426f27e04705.tar.gz
gnu: go-github-com-thejerf-suture: Update to 3.0.2.
* gnu/packages/syncthing.scm (go-github-com-thejerf-suture): Update to 3.0.2.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 41b6082182..3dfb50ee94 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -521,25 +521,23 @@ database in Go.")
(license bsd-2))))
(define-public go-github-com-thejerf-suture
- (let ((commit "bf6ee6a0b047ebbe9ae07d847f750dd18c6a9276")
- (revision "0"))
- (package
- (name "go-github-com-thejerf-suture")
- (version (git-version "3.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/thejerf/suture")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0rzx9k408vaglwnnpgpcs6y7ff7p65915nbg33rvbaz13hxwkz3y"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/thejerf/suture"))
- (synopsis "Supervisor trees for Go")
- (description "Suture provides Erlang-ish supervisor trees for Go.
+ (package
+ (name "go-github-com-thejerf-suture")
+ (version "3.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thejerf/suture")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03bdrl78jfwk0kw40lj63ga9cxhgccgss8yi9lp5j0m0ml7921gh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/thejerf/suture"))
+ (synopsis "Supervisor trees for Go")
+ (description "Suture provides Erlang-ish supervisor trees for Go.
\"Supervisor trees\" -> \"sutree\" -> \"suture\" -> holds your code together
when it's trying to die.
@@ -548,8 +546,8 @@ with supervision trees (such as burning all your CPU time endlessly restarting
dead services), while also making no unnecessary demands on the \"service\"
code, and providing hooks to perform adequate logging with in a production
environment")
- (home-page "https://github.com/thejerf/suture")
- (license expat))))
+ (home-page "https://github.com/thejerf/suture")
+ (license expat)))
(define-public go-github-com-vitrun-qart-coding
(let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")