summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-05-01 10:45:59 -0400
committerLeo Famulari <leo@famulari.name>2018-05-01 10:52:55 -0400
commit2849c6657673a9f0788e593ab72e36a80049221f (patch)
tree2895d90503a36dba2c349847fcfb4c57f01ef384 /gnu/packages/syncthing.scm
parentca14531a5f8b351167ac90e8c1755b5166775e4a (diff)
downloadpatches-2849c6657673a9f0788e593ab72e36a80049221f.tar
patches-2849c6657673a9f0788e593ab72e36a80049221f.tar.gz
gnu: syncthing: Use Syncthing's fork of the notify module.
* gnu/packages/syncthing.scm (go-github-com-zillode-notify): Replace with ... (go-github-com-syncthing-notify): ... this new variable. (syncthing)[inputs]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 23e45a580b..152477bb06 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -144,7 +144,7 @@
("go-golang-org-x-net-union" ,(go-golang-org-x-net-union))
("go-golang-org-x-text" ,(go-golang-org-x-text-union))
("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)
- ("go-github-com-zillode-notify" ,go-github-com-zillode-notify)
+ ("go-github-com-syncthing-notify" ,go-github-com-syncthing-notify)
;; For tests
("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
(synopsis "Decentralized continuous file system synchronization")
@@ -1107,30 +1107,30 @@ using sh's word-splitting rules.")
(home-page "https://github.com/kballard/go-shellquote")
(license expat))))
-(define-public go-github-com-zillode-notify
- (let ((commit "53dd6873a851fc377c87d82f994b1fecdf25aadb")
- (revision "3"))
+(define-public go-github-com-syncthing-notify
+ (let ((commit "b9ceffc925039c77cd9e0d38f248279ccc4399e2")
+ (revision "0"))
(package
- (name "go-github-com-zillode-notify")
+ (name "go-github-com-syncthing-notify")
(version (git-version "0.0.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/calmh/notify")
+ (url "https://github.com/syncthing/notify")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "0ar6mj6s91y7hc5gdp88lz3i7xi29cqkx9f090xj899ir21a8djn"))))
+ "1scha9b2r35bvqzqx86sarzjxf72ywvj3g6n9pm3xq4i4xzpylxf"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/Zillode/notify"))
+ '(#:import-path "github.com/syncthing/notify"))
(propagated-inputs
`(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
(synopsis "File system event notification library")
(description "This package provides @code{notify}, a file system event
notification library in Go.")
- (home-page "https://github.com/zillode/notify")
+ (home-page "https://github.com/syncthing/notify")
(license expat))))
(define-public go-github-com-beorn7-perks-quantile