summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-30 16:06:56 -0500
committerLeo Famulari <leo@famulari.name>2018-01-10 01:22:02 -0800
commite62d057505de7961d23431778e851d5133bcfc36 (patch)
tree794f48e3b26c96f500fbcad6baca4d0dd7e4e0cf /gnu/packages/syncthing.scm
parent63aade459df7ff91519c6815ba4fa02b94642715 (diff)
downloadpatches-e62d057505de7961d23431778e851d5133bcfc36.tar
patches-e62d057505de7961d23431778e851d5133bcfc36.tar.gz
gnu: Add go-github-com-klauspost-reedsolomon.
* gnu/packages/syncthing.scm (go-github-com-klauspost-reedsolomon): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 44023617ec..8f6b1f5052 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1917,3 +1917,30 @@ notification library in Go.")
(description "This package provides @code{cpuid}, a Go library that provides information about the CPU running the current program")
(home-page "https://github.com/klauspost/cpuid")
(license expat))))
+
+(define-public go-github-com-klauspost-reedsolomon
+ (let ((commit "0b30fa71cc8e4e9010c9aba6d0320e2e5b163b29")
+ (revision "0"))
+ (package
+ (name "go-github-com-klauspost-reedsolomon")
+ (version (git-version "1.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/klauspost/reedsolomon.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04jvf65ybsa7w4d7s2n0s174p0q2fl0dqd5hhn2krw66z9i3rc6d"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/klauspost/reedsolomon"))
+ (propagated-inputs
+ `(("go-github-com-klauspost-cpuid"
+ ,go-github-com-klauspost-cpuid)))
+ (synopsis "Reed-Solomon Erasure Coding in Go")
+ (description "This package provides and implemenation of Reed-Solomon
+Erasure Coding in Go.")
+ (home-page "https://github.com/klauspost/reedsolomon")
+ (license expat))))