summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 19:09:24 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:16 -0500
commita04434f291acf55129b3202833023c5b88eed8c9 (patch)
treecd99e51c2bc0e3e44fd3bf4e934d34638983274d /gnu/packages/syncthing.scm
parent6666f4f41fb2ec5294676cf62ff265c43be3f972 (diff)
downloadpatches-a04434f291acf55129b3202833023c5b88eed8c9.tar
patches-a04434f291acf55129b3202833023c5b88eed8c9.tar.gz
gnu: Add go-github-com-beorn7-perks-quantile.
* gnu/packages/syncthing.scm (go-github-com-beorn7-perks-quantile): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 3fb70d13da..bee584050b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1927,3 +1927,29 @@ notification library in Go.")
Erasure Coding in Go.")
(home-page "https://github.com/klauspost/reedsolomon")
(license expat))))
+
+(define-public go-github-com-beorn7-perks-quantile
+ (let ((commit "4c0e84591b9aa9e6dcfdf3e020114cd81f89d5f9")
+ (revision "0"))
+ (package
+ (name "go-github-com-beorn7-perks-quantile")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beorn7/perks.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hrybsql68xw57brzj805xx2mghydpdiysv3gbhr7f5wlxj2514y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/beorn7/perks/quantile"
+ #:unpack-path "github.com/beorn7/perks"))
+ (synopsis "Compute approximate quantiles over an unbounded data stream")
+ (description "Perks contains the Go package @code{quantile} that computes
+approximate quantiles over an unbounded data stream within low memory and CPU
+bounds.")
+ (home-page "https://github.com/beorn7/perks")
+ (license expat))))