summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-29 17:19:26 -0400
committerLeo Famulari <leo@famulari.name>2018-10-02 15:40:52 -0400
commit712d01bbe9de285bb3007511c94957b13b74118e (patch)
tree0692005e531e2eca9d3046a7052aaedd67277163 /gnu/packages/syncthing.scm
parent994bccd9443032141accede0e403cbfb62f6c63e (diff)
downloadpatches-712d01bbe9de285bb3007511c94957b13b74118e.tar
patches-712d01bbe9de285bb3007511c94957b13b74118e.tar.gz
gnu: Add gopkg.in/asn1-ber.v1.
* gnu/packages/syncthing.scm (go-gopkg.in-asn1-ber.v1): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 29caaaf02e..61b45e111f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1366,3 +1366,25 @@ Prometheus HTTP API.")
(description "This is a union of Go Prometheus libraries")
(home-page (package-home-page go-github-com-client-golang-prometheus))
(license (package-license go-github-com-client-golang-prometheus))))
+
+(define-public go-gopkg.in-asn1-ber.v1
+ (package
+ (name "go-gopkg.in-asn1-ber.v1")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/asn1-ber.v1")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1y8bvzbxpw0lfnn7pbcdwzqj4l90qj6xf88dvv9pxd9yl5g6cskx"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/asn1-ber.v1"))
+ (synopsis "ASN.1 BER encoding and decoding in Go")
+ (description "This package provides ASN.1 BER encoding and decoding in the
+Go language.")
+ (home-page "https://gopkg.in/asn1-ber.v1")
+ (license expat)))