summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:11:57 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:51 -0400
commit04e2d470ab5a6796599c20a5b72f906ba5990262 (patch)
tree2570454fb9de3815806d87f04d6d5fac35c0c70a /gnu/packages/syncthing.scm
parent8c73bb2c72470f03840698df835febacc41ccb66 (diff)
downloadpatches-04e2d470ab5a6796599c20a5b72f906ba5990262.tar
patches-04e2d470ab5a6796599c20a5b72f906ba5990262.tar.gz
gnu: Add go-golang-org-x-net-proxy.
* gnu/packages/syncthing.scm (go-golang-org-x-net-proxy): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 177a4f0c75..ed1bafdaba 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1114,6 +1114,32 @@ IP-level socket options for the Internet Protocol version 6.")
(home-page "https://go.googlesource.com/net")
(license bsd-3))))
+(define-public go-golang-org-x-net-proxy
+ (let ((commit "ffcf1bedda3b04ebb15a168a59800a73d6dc0f4d")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-net-proxy")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/net")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-net-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "1ifqw09pj9q23mza1d0im99yy3jp72dvq9dcx2bs1n1m11cjdjzp"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/net/proxy"
+ #:unpack-path "golang.org/x/net/"))
+ (synopsis "Go support for network proxies")
+ (description "This packages provides @code{proxy}, which provides support
+for a variety of protocols to proxy network data.")
+ (home-page "https://go.googlesource.com/net")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))