summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-22 18:27:12 -0400
committerLeo Famulari <leo@famulari.name>2017-04-22 18:27:12 -0400
commit1524851f58d8d69f6c6e1c6406cf174083bbe82d (patch)
treed7c63b716501e4423e9f7173790a8cc4c3962935 /gnu/packages/suckless.scm
parent0802f3a034815576bf0e28c59c968400566b418b (diff)
parented9fb46b16cf7632e6df15c52c7183807fe5d1f9 (diff)
downloadpatches-1524851f58d8d69f6c6e1c6406cf174083bbe82d.tar
patches-1524851f58d8d69f6c6e1c6406cf174083bbe82d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 223a17f443..a87e665d2b 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -174,7 +174,7 @@ numbers of user-defined menu items efficiently.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -189,7 +189,7 @@ numbers of user-defined menu items efficiently.")
("libxkbfile" ,libxkbfile)
("alsa-lib" ,alsa-lib)
("libmpdclient" ,libmpdclient)))
- (home-page "http://git.2f30.org/spoon/")
+ (home-page "https://git.2f30.org/spoon/")
(synopsis "Set dwm status")
(description
"Spoon can be used to set the dwm status.")
@@ -355,7 +355,7 @@ few minutes.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -367,7 +367,7 @@ few minutes.")
(string-append "PREFIX=" %output))))
(inputs
`(("libx11" ,libx11)))
- (home-page "http://git.2f30.org/xbattmon/")
+ (home-page "https://git.2f30.org/xbattmon/")
(synopsis "Simple battery monitor for X")
(description
"Xbattmon is a simple battery monitor for X.")
@@ -380,7 +380,7 @@ few minutes.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -393,7 +393,7 @@ few minutes.")
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; No configure script
- (home-page "http://git.2f30.org/wificurse/")
+ (home-page "https://git.2f30.org/wificurse/")
(synopsis "Wifi DoS attack tool")
(description
"Wificurses listens for beacons sent from wireless access points
@@ -413,7 +413,7 @@ drivers capable of injecting packets in wireless networks.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -426,7 +426,7 @@ drivers capable of injecting packets in wireless networks.")
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; No configure script
- (home-page "http://2f30.org")
+ (home-page "https://2f30.org/")
(synopsis "Commandline utility which scrolls text")
(description
"Skroll is a small utility that you can use to make a text scroll.
@@ -441,7 +441,7 @@ left.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -454,7 +454,7 @@ left.")
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; No configure script
- (home-page "http://git.2f30.org/sbm/")
+ (home-page "https://git.2f30.org/sbm/")
(synopsis "Simple bandwidth monitor")
(description
"Sbm is a simple bandwidth monitor.")
@@ -467,7 +467,7 @@ left.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -483,7 +483,7 @@ left.")
(inputs
`(("cups-minimal" ,cups-minimal)
("zlib" ,zlib)))
- (home-page "http://git.2f30.org/prout/")
+ (home-page "https://git.2f30.org/prout/")
(synopsis "Smaller lp command")
(description
"Prout (PRint OUT) is a small utility one can use to send
@@ -500,7 +500,7 @@ cups server to be installed.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -519,7 +519,7 @@ cups server to be installed.")
(("lcurses") "lncurses")))))))
(inputs
`(("ncurses" ,ncurses)))
- (home-page "http://git.2f30.org/noice/")
+ (home-page "https://git.2f30.org/noice/")
(synopsis "Small file browser")
(description
"Noice is a small curses-based file browser.")
@@ -550,7 +550,7 @@ cups server to be installed.")
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; No configure script
- (home-page "http://git.2f30.org/human/")
+ (home-page "https://git.2f30.org/human/")
(synopsis "Convert bytes to human readable formats")
(description
"Human is a small program which translate numbers into a
@@ -567,7 +567,7 @@ environment variable.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -580,22 +580,22 @@ environment variable.")
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; No configure script
- (home-page "http://git.2f30.org/fortify-headers/")
+ (home-page "https://git.2f30.org/fortify-headers/")
(synopsis "Standalone fortify-source implementation")
(description
"This is a standalone implementation of fortify source. It provides
compile time buffer checks. It is libc-agnostic and simply overlays the
system headers by using the @code{#include_next} extension found in GCC. It was
-initially intended to be used on musl based Linux distributions.
+initially intended to be used on musl-based Linux distributions.
@itemize
@item It is portable, works on *BSD, Linux, Solaris and possibly others.
@item It will only trap non-conformant programs. This means that fortify
level 2 is treated in the same way as level 1.
@item Avoids making function calls when undefined behaviour has already been
- invoked. This is handled by using __builtin_trap().
-@item Support for out-of-bounds read interfaces, such as send(), write(),
- fwrite() etc.
+ invoked. This is handled by using @code{__builtin_trap()}.
+@item Support for out-of-bounds read interfaces, such as @code{send()},
+ @code{write()}, @code{fwrite()}, etc.
@item No ABI is enforced. All of the fortify check functions are inlined
into the resulting binary.
@end itemize\n")
@@ -608,7 +608,7 @@ initially intended to be used on musl based Linux distributions.
(source
(origin
(method url-fetch)
- (uri (string-append "http://dl.2f30.org/releases/"
+ (uri (string-append "https://dl.2f30.org/releases/"
name "-" version ".tar.gz"))
(sha256
(base32
@@ -623,7 +623,7 @@ initially intended to be used on musl based Linux distributions.
(delete 'configure)))) ; No configure script
(inputs
`(("libpng" ,libpng)))
- (home-page "http://git.2f30.org/colors/")
+ (home-page "https://git.2f30.org/colors/")
(synopsis "Extract colors from pictures")
(description
"Extract colors from PNG files. It is similar to