summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-27 13:52:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-28 15:51:05 +0200
commit174fbd5f3b2f286cf06e58787853db6b8f0f5b35 (patch)
treebe8763fe52407a4c226d99259e242f2dab0e3a3f /gnu/packages/statistics.scm
parentaf9bb4cab837f88b03290729ec78288853668cca (diff)
downloadpatches-174fbd5f3b2f286cf06e58787853db6b8f0f5b35.tar
patches-174fbd5f3b2f286cf06e58787853db6b8f0f5b35.tar.gz
gnu: r-minimal: Remove timestamp from man page.
* gnu/packages/statistics.scm (r-minimal)[arguments]: Adjust "build-reproducibly" phase to prevent the bundled help2man script from printing the current month and year.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1fe82d5d99..a6c1f046dc 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -185,6 +185,14 @@ be output in text, PostScript, PDF or HTML.")
(substitute* "src/library/tools/Makefile.in"
(("(install_package_description\\(.*\"')\\)\"" line prefix)
(string-append prefix ", builtStamp='1970-01-01')\"")))
+
+ ;; R bundles an older version of help2man, which does not respect
+ ;; SOURCE_DATE_EPOCH. We cannot just use the latest help2man,
+ ;; because that breaks a test.
+ (with-fluids ((%default-port-encoding "ISO-8859-1"))
+ (substitute* "tools/help2man.pl"
+ (("my \\$date = strftime \"%B %Y\", localtime" line)
+ (string-append line " 1"))))
#t))
(add-before 'configure 'set-default-pager
;; Set default pager to "cat", because otherwise it is "false",