summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:16:47 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commitc5bf3abe34718991a9441e0f036a6d1d86731bf7 (patch)
treeac3e0e904c235eca27cad0aedca1d93b57eba931 /gnu/packages/statistics.scm
parent256ccc926c31dbb5bb1a70af30a5403e91b132e3 (diff)
downloadpatches-c5bf3abe34718991a9441e0f036a6d1d86731bf7.tar
patches-c5bf3abe34718991a9441e0f036a6d1d86731bf7.tar.gz
gnu: Add r-formatr.
* gnu/packages/statistics.scm (r-formatr): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9acc20b5eb..ff7f0174e5 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -580,3 +580,23 @@ evaluation and display of R code, with enough information that you can
accurately recreate what happens at the command line. The tools can easily be
adapted for other output formats, such as HTML or LaTeX.")
(license license:gpl3+)))
+
+(define-public r-formatr
+ (package
+ (name "r-formatr")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "formatR" version))
+ (sha256
+ (base32
+ "0f4cv2zv5wayyqx99ybfyl0p83kgjvnsv8dhcwa4s49kw6jsx1lr"))))
+ (build-system r-build-system)
+ (home-page "http://yihui.name/formatR")
+ (synopsis "Format R code automatically")
+ (description
+ "This package provides a function to format R source code. Spaces and
+indent will be added to the code automatically, and comments will be preserved
+under certain conditions, so that R code will be more human-readable and tidy.
+There is also a Shiny app as a user interface in this package.")
+ (license license:gpl3+)))