summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-02 13:44:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-02 13:44:43 +0200
commite0f897035779f3344dc2553aa10f3a4465d290e3 (patch)
treeab39d10c892b627b8e057110f16d0f8c7ad83727 /gnu/packages/statistics.scm
parenta13c1bf4ca0b15fa53235c2bd6aa53e4a75c7d0f (diff)
parent92963798a6b81989c52bc199ef224605d9b90063 (diff)
downloadpatches-e0f897035779f3344dc2553aa10f3a4465d290e3.tar
patches-e0f897035779f3344dc2553aa10f3a4465d290e3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm33
1 files changed, 22 insertions, 11 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 434f26dbe3..3996eb91e4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -113,10 +113,10 @@ be output in text, PostScript, PDF or HTML.")
;; Update this package together with the set of recommended packages: r-boot,
;; r-class, r-cluster, r-codetools, r-foreign, r-kernsmooth, r-lattice,
;; r-mass, r-matrix, r-mgcv, r-nlme, r-nnet, r-rpart, r-spatial, r-survival.
-(define-public r-minimal
+(define r-with-tests
(package
- (name "r-minimal")
- (version "3.4.4")
+ (name "r-with-tests")
+ (version "3.5.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -124,7 +124,7 @@ be output in text, PostScript, PDF or HTML.")
version ".tar.gz"))
(sha256
(base32
- "0dq3jsnwsb5j3fhl0wi3p5ycv8avf8s5j1y4ap3d2mkjmcppvsdk"))))
+ "0w38865laqg28cdhikxdxhx4rfp0kgcn72gakwypsy91br9ja5zx"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -217,11 +217,9 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(add-after 'build 'install-info
(lambda _ (zero? (system* "make" "install-info")))))
#:configure-flags
- `(;; Do not build the recommended packages. The build system creates
- ;; random temporary directories and embeds their names in some
- ;; package files. We build these packages with the r-build-system
- ;; instead.
- "--without-recommended-packages"
+ `(;; We build the recommended packages here, because they are needed in
+ ;; order to run the test suite. We disable them in the r-minimal
+ ;; package.
"--with-cairo"
"--with-blas=-lopenblas"
"--with-libpng"
@@ -292,6 +290,19 @@ publication-quality data plots. A large amount of 3rd-party packages are
available, greatly increasing its breadth and scope.")
(license license:gpl3+)))
+(define-public r-minimal
+ (package (inherit r-with-tests)
+ (name "r-minimal")
+ (arguments
+ `(#:tests? #f
+ ,@(substitute-keyword-arguments (package-arguments r-with-tests)
+ ((#:configure-flags flags)
+ ;; Do not build the recommended packages. The build system creates
+ ;; random temporary directories and embeds their names in some
+ ;; package files. We build these packages with the r-build-system
+ ;; instead.
+ `(cons "--without-recommended-packages" ,flags)))))))
+
(define-public rmath-standalone
(package (inherit r-minimal)
(name "rmath-standalone")
@@ -3522,13 +3533,13 @@ vignettes.")
(define-public r-mvtnorm
(package
(name "r-mvtnorm")
- (version "1.0-7")
+ (version "1.0-8")
(source (origin
(method url-fetch)
(uri (cran-uri "mvtnorm" version))
(sha256
(base32
- "0f7hzflygdnbwvzadr3knhybhanwg7agqddclj6mhbvwqpgb0qyh"))))
+ "0la42lylb7cjrcrc285bn69bz9kyg556xw317iz139dp1yswl410"))))
(build-system r-build-system)
(inputs
`(("gfortran" ,gfortran)))