summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-10-31 14:09:28 -0400
committerLudovic Courtès <ludo@gnu.org>2017-11-09 23:54:48 +0100
commite99f045cc81c57d28a0edd0359e4cd76136eea9d (patch)
tree63a9401abb944aa8c3931bbdf7f8f27a14f162c6 /gnu/packages/statistics.scm
parentd3150731a81eb4ba97cb33ac71ad686b09302900 (diff)
downloadpatches-e99f045cc81c57d28a0edd0359e4cd76136eea9d.tar
patches-e99f045cc81c57d28a0edd0359e4cd76136eea9d.tar.gz
gnu: Add r-directlabels.
* gnu/packages/statistics.scm (r-directlabels): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a7b4532e7a..c7ebb84249 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5530,3 +5530,27 @@ tools.")
"The goal of tgconfig is to provide infrastructure for managing package
parameters.")
(license license:gpl3))))
+
+(define-public r-directlabels
+ (package
+ (name "r-directlabels")
+ (version "2017.03.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "directlabels" version))
+ (sha256
+ (base32
+ "01ahw0c56mnzwl611s8hnghicww4c4dgf5v2wv6bl1s1pramw9pr"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-quadprog" ,r-quadprog)))
+ (home-page "http://directlabels.r-forge.r-project.org/")
+ (synopsis "Direct labels for multicolor plots")
+ (description
+ "This package provides an extensible framework for automatically placing
+direct labels onto multicolor plots. Label positions are described using
+positioning methods that can be re-used across several different plots. There
+are heuristics for examining @code{trellis} and @code{ggplot} objects and
+inferring an appropriate positioning method.")
+ (license license:gpl3)))