summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-01-12 15:14:04 +0100
committerRoel Janssen <roel@gnu.org>2017-01-12 15:14:04 +0100
commitac1f1e4e0229bb9f2a72af1d9b529dda63e862e1 (patch)
tree1b174805aad6a963b82f280d7b014cd940b96563 /gnu/packages/statistics.scm
parent409c5733224f714096d0e2a665b85d64c96c7088 (diff)
downloadpatches-ac1f1e4e0229bb9f2a72af1d9b529dda63e862e1.tar
patches-ac1f1e4e0229bb9f2a72af1d9b529dda63e862e1.tar.gz
gnu: Add r-ggthemes.
* gnu/packages/statistics.scm (r-ggthemes): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 40a511b6ed..db1a6871ad 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3954,6 +3954,31 @@ such that the arrangement of points within a category reflects the density of
data at that region, and avoids over-plotting.")
(license license:gpl2+)))
+(define-public r-ggthemes
+ (package
+ (name "r-ggthemes")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggthemes" version))
+ (sha256
+ (base32
+ "1qdxg2siwsiq32fmgcxn4vihgxad9v8q0aqigl7a94c26bwxs7y2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-colorspace" ,r-colorspace)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-scales" ,r-scales)))
+ (home-page "https://cran.rstudio.com/web/packages/ggthemes")
+ (synopsis "Extra themes, scales and geoms for @code{ggplot2}")
+ (description "This package provides extra themes and scales for
+@code{ggplot2} that replicate the look of plots by Edward Tufte and
+Stephen Few in Fivethirtyeight, The Economist, Stata, Excel, and The
+Wall Street Journal, among others. This package also provides
+@code{geoms} for Tufte's box plot and range frame.")
+ (license license:gpl2)))
+
(define-public r-statmod
(package
(name "r-statmod")