summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-24 15:15:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-28 22:43:16 +0100
commit1bd46f55207f5940131e37678bdd10ccff1dd56d (patch)
treeacc893ccb7224e1acc32e77635562ff585849ef5 /gnu/packages/statistics.scm
parentc4708783eec4cf0d312b6401949b15e76407b724 (diff)
downloadpatches-1bd46f55207f5940131e37678bdd10ccff1dd56d.tar
patches-1bd46f55207f5940131e37678bdd10ccff1dd56d.tar.gz
gnu: Add r-fastcluster.
* gnu/packages/statistics.scm (r-fastcluster): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d2ca35ef6b..3c2bd0c03c 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3539,6 +3539,31 @@ hierarchical clustering dendrograms.")
routines.")
(license license:lgpl2.0+)))
+(define-public r-fastcluster
+ (package
+ (name "r-fastcluster")
+ (version "1.1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastcluster" version))
+ (sha256
+ (base32
+ "0rlbxhh894znf10x0xgkv9dzpibgq9jw5aqpgviccdnxc2c5hwid"))))
+ (build-system r-build-system)
+ (home-page "http://danifold.net/fastcluster.html")
+ (synopsis "Fast hierarchical clustering routines")
+ (description
+ "This package implements fast hierarchical, agglomerative clustering
+routines. Part of the functionality is designed as drop-in replacement for
+existing routines: @code{linkage()} in the SciPy package
+@code{scipy.cluster.hierarchy}, @code{hclust()} in R's @code{stats} package,
+and the @code{flashClust} package. It provides the same functionality with
+the benefit of a much faster implementation. Moreover, there are
+memory-saving routines for clustering of vector data, which go beyond what the
+existing packages provide.")
+ (license license:bsd-2)))
+
(define-public r-kernsmooth
(package
(name "r-kernsmooth")