summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-12 00:11:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-17 10:14:00 +0100
commit8f0069170c261642fd0b3128c3eb194e4ba2efca (patch)
tree832d142b070c09e94c85259b2eda060e5baf139f /gnu/packages/statistics.scm
parent708b54a99252d3929b8062bc57167cc6d097a126 (diff)
downloadpatches-8f0069170c261642fd0b3128c3eb194e4ba2efca.tar
patches-8f0069170c261642fd0b3128c3eb194e4ba2efca.tar.gz
gnu: Add r-boot.
* gnu/packages/statistics.scm (r-boot): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 75bdb5df83..54305a2f86 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -220,6 +220,27 @@ publication-quality data plots. A large amount of 3rd-party packages are
available, greatly increasing its breadth and scope.")
(license license:gpl3+)))
+(define-public r-boot
+ (package
+ (name "r-boot")
+ (version "1.3-18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "boot" version))
+ (sha256
+ (base32
+ "0pi348vvgzn1ny54yxhw6kq6nl7rx9bpr9ji1a6wqs8ah5zj7z8j"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/boot")
+ (synopsis "Bootstrap functions for R")
+ (description
+ "This package provides functions and datasets for bootstrapping from the
+book \"Bootstrap Methods and Their Application\" by A.C. Davison and
+D.V. Hinkley (1997, CUP), originally written by Angelo Canty for S.")
+ ;; Unlimited distribution
+ (license (license:non-copyleft "file://R/bootfuns.q"))))
+
(define-public r-bit
(package
(name "r-bit")