summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-24 09:05:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-24 09:23:18 +0200
commit3146aab7a8d5529599d755fe42ff37965b3415e6 (patch)
treefe1c1c5689e7d9430af09df8dcd1add0e1b4a500 /gnu/packages/statistics.scm
parent11c237f54e4de5916e204aba574ab15f7818a3f5 (diff)
downloadpatches-3146aab7a8d5529599d755fe42ff37965b3415e6.tar
patches-3146aab7a8d5529599d755fe42ff37965b3415e6.tar.gz
gnu: r-minimal: Add tcl/tk support.
* gnu/packages/statistics.scm (r-minimal)[inputs]: Add tcl and tk. [arguments]: Add configure flags to enable tcl and tk support.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index b9ac3e6dc7..38d253b1ce 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
#:use-module (gnu packages ssh)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -216,7 +217,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(add-after 'build 'install-info
(lambda _ (zero? (system* "make" "install-info")))))
#:configure-flags
- '(;; Do not build the recommended packages. The build system creates
+ `(;; Do not build the recommended packages. The build system creates
;; random temporary directories and embeds their names in some
;; package files. We build these packages with the r-build-system
;; instead.
@@ -227,6 +228,13 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
"--with-jpeglib"
"--with-libtiff"
"--with-ICU"
+ "--with-tcltk"
+ ,(string-append "--with-tcl-config="
+ (assoc-ref %build-inputs "tcl")
+ "/lib/tclConfig.sh")
+ ,(string-append "--with-tk-config="
+ (assoc-ref %build-inputs "tk")
+ "/lib/tkConfig.sh")
"--enable-R-shlib"
"--enable-BLAS-shlib"
"--with-system-tre")))
@@ -265,6 +273,8 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
;; This avoids a reference to the ungraftable static bash. R uses the
;; detected shell for the "system" procedure.
("bash" ,bash-minimal)
+ ("tcl" ,tcl)
+ ("tk" ,tk)
("which" ,which)
("zlib" ,zlib)))
(native-search-paths