summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-19 18:46:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-19 18:46:22 +0100
commit7c9d8a5d58d6797a4c224bc76b823d826ceede4b (patch)
treee6c8970f40c2bd998ffc8b83ce3d44d4f34f6a60 /gnu/packages/statistics.scm
parentbfb6c393b91dc4a236678a0682348d5b7bd77193 (diff)
downloadpatches-7c9d8a5d58d6797a4c224bc76b823d826ceede4b.tar
patches-7c9d8a5d58d6797a4c224bc76b823d826ceede4b.tar.gz
gnu: r-nmf: Move to (gnu packages bioconductor).
* gnu/packages/statistics.scm (r-nmf): Move this variable from here... * gnu/packages/bioconductor.scm (r-nmf): ...to here.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 313634c29c..4b1b34cd3b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3420,46 +3420,6 @@ memory-mapped files.")
;; Users can choose either LGPLv3 or ASL2.0.
(license (list license:lgpl3 license:asl2.0))))
-(define-public r-nmf
- (package
- (name "r-nmf")
- (version "0.21.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "NMF" version))
- (sha256
- (base32
- "1qq25n3k5sgh3srlshb3ic6q92s12c1ilqf5cd5anvq6cqfchc1v"))))
- (properties `((upstream-name . "NMF")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-cluster" ,r-cluster)
- ("r-bigmemory" ,r-bigmemory) ; suggested
- ("r-synchronicity" ,r-synchronicity) ; suggested
- ("r-colorspace" ,r-colorspace)
- ("r-digest" ,r-digest)
- ("r-doparallel" ,r-doparallel)
- ("r-foreach" ,r-foreach)
- ("r-ggplot2" ,r-ggplot2)
- ("r-gridbase" ,r-gridbase)
- ("r-pkgmaker" ,r-pkgmaker)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-registry" ,r-registry)
- ("r-reshape2" ,r-reshape2)
- ("r-rngtools" ,r-rngtools)
- ("r-stringr" ,r-stringr)))
- (home-page "http://renozao.github.io/NMF")
- (synopsis "Algorithms and framework for nonnegative matrix factorization")
- (description
- "This package provides a framework to perform Non-negative Matrix
-Factorization (NMF). The package implements a set of already published
-algorithms and seeding methods, and provides a framework to test, develop and
-plug new or custom algorithms. Most of the built-in algorithms have been
-optimized in C++, and the main interface function provides an easy way of
-performing parallel computations on multicore machines.")
- (license license:gpl2+)))
-
(define-public r-r-methodss3
(package
(name "r-r-methodss3")