summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
commitebb7cf9e21060105d9950dd5142c0eb918083666 (patch)
tree36c1607b80d92e27fb9d09029d1d3b57a1fd5065 /gnu/packages/ssh.scm
parent0b870f7915f5da43758753fd088a22033936dc50 (diff)
parentc2d7e800e6788277bc56f31d5836f9d507dc1506 (diff)
downloadpatches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar
patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm44
1 files changed, 25 insertions, 19 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 2efc6ed7a5..4d062bbb18 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -90,7 +90,8 @@
;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
#:tests? #f))
(inputs `(("zlib" ,zlib)
- ("libgcrypt" ,libgcrypt)))
+ ("libgcrypt" ,libgcrypt)
+ ("mit-krb5" ,mit-krb5)))
(synopsis "SSH client library")
(description
"libssh is a C library implementing the SSHv2 and SSHv1 protocol for client
@@ -130,14 +131,14 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "8.0p1")
+ (version "8.2p1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
- name "-" version ".tar.gz"))
+ "openssh-" version ".tar.gz"))
(sha256
(base32
- "0s7xh4s0qcipnjh9ls5blxcpvhyd116z9dxn3q1yi64lwrwki55x"))))
+ "0wg6ckzvvklbzznijxkk28fb8dnwyjd0w30ra0afwv6gwr8m34j3"))))
(build-system gnu-build-system)
(native-inputs `(("groff" ,groff)
("pkg-config" ,pkg-config)))
@@ -146,7 +147,7 @@ a server that supports the SSH-2 protocol.")
("pam" ,linux-pam)
("mit-krb5" ,mit-krb5)
("zlib" ,zlib)
- ("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
+ ("xauth" ,xauth))) ; for 'ssh -X' and 'ssh -Y'
(arguments
`(#:test-target "tests"
;; Otherwise, the test scripts try to use a nonexistent directory and
@@ -157,12 +158,12 @@ a server that supports the SSH-2 protocol.")
;; Default value of 'PATH' used by sshd.
"--with-default-path=/run/current-system/profile/bin"
- ;; configure needs to find krb5-config
+ ;; configure needs to find krb5-config.
,(string-append "--with-kerberos5="
(assoc-ref %build-inputs "mit-krb5")
"/bin")
- ;; libedit needed for sftp completion
+ ;; libedit is needed for sftp completion.
"--with-libedit"
;; Enable PAM support in sshd.
@@ -187,14 +188,18 @@ a server that supports the SSH-2 protocol.")
#t)))
(add-before 'check 'patch-tests
(lambda _
- ;; remove 't-exec' regress target which requires user 'sshd'
- (substitute* "regress/Makefile"
- (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
+ (substitute* "regress/test-exec.sh"
+ (("/bin/sh") (which "sh")))
+
+ ;; Remove 't-exec' regress target which requires user 'sshd'.
+ (substitute* (list "Makefile"
+ "regress/Makefile")
+ (("^(tests:.*) t-exec(.*)" all pre post)
(string-append pre post)))
#t))
(replace 'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
- ;; install without host keys and system configuration files
+ ;; Install without host keys and system configuration files.
(apply invoke "make" "install-nosysconf" make-flags)
(install-file "contrib/ssh-copy-id"
(string-append (assoc-ref outputs "out")
@@ -749,23 +754,24 @@ of existing remote shell facilities such as SSH.")
(define-public endlessh
(package
(name "endlessh")
- (version "1.0")
+ (version "1.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/skeeto/endlessh/releases/"
- "download/" version "/endlessh-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skeeto/endlessh.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0hhsr65hzrcb7ylskmxyr92svzndhks8hqzn8hvg7f7j89rkvq5k"))))
+ (base32 "0ziwr8j1frsp3dajr8h5glkm1dn5cci404kazz5w1jfrp0736x68"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"CC=gcc")
- #:tests? #f ; no test target
+ #:tests? #f ; no test target
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/skeeto/endlessh")
(synopsis "SSH tarpit that slowly sends an endless banner")
(description