summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 21:35:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:22 +0200
commite7c37ed590cad02d4d2f0e86ce5fcb3f15c69fb8 (patch)
treeaa090a4022948367eb823d0987c8bcd1dde5fe4c /gnu/packages/ssh.scm
parent9947dcd746deaacf239f51eff06cf6faa523060b (diff)
downloadpatches-e7c37ed590cad02d4d2f0e86ce5fcb3f15c69fb8.tar
patches-e7c37ed590cad02d4d2f0e86ce5fcb3f15c69fb8.tar.gz
gnu: guile-ssh: Return #t from all phases.
* gnu/packages/ssh.scm (guile-ssh)[arguments]: Substitute INVOKE for SYSTEM* and all its trappings.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index dd8518002d..6a690c7dde 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -256,22 +256,22 @@ Additionally, various channel-specific options can be negotiated.")
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'autoreconf
(lambda* (#:key inputs #:allow-other-keys)
- (zero? (system* "autoreconf" "-vfi"))))
+ (invoke "autoreconf" "-vfi")))
(add-before 'build 'fix-libguile-ssh-file-name
(lambda* (#:key outputs #:allow-other-keys)
;; Build and install libguile-ssh.so so that we can use
;; its absolute file name in .scm files, before we build
;; the .go files.
- (and (zero? (system* "make" "install"
- "-C" "libguile-ssh"
- "-j" (number->string
- (parallel-job-count))))
- (let* ((out (assoc-ref outputs "out"))
- (libdir (string-append out "/lib")))
- (substitute* (find-files "." "\\.scm$")
- (("\"libguile-ssh\"")
- (string-append "\"" libdir "/libguile-ssh\"")))
- #t))))
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (invoke "make" "install"
+ "-C" "libguile-ssh"
+ "-j" (number->string
+ (parallel-job-count)))
+ (substitute* (find-files "." "\\.scm$")
+ (("\"libguile-ssh\"")
+ (string-append "\"" lib "/libguile-ssh\"")))
+ #t)))
(add-after 'install 'remove-bin-directory
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))