summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-01 13:46:35 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-01 14:18:38 +0200
commit44fd0994a0eb06a2f2b639f529ca8f64969c8736 (patch)
tree08ec6d60da9f402f78d170c9aada66a91e8e36be /gnu/packages/ssh.scm
parent87390c155eb6ab0c6ed037104eeae3ba7925316a (diff)
downloadpatches-44fd0994a0eb06a2f2b639f529ca8f64969c8736.tar
patches-44fd0994a0eb06a2f2b639f529ca8f64969c8736.tar.gz
gnu: guile-ssh: Update to 0.8.0.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.8.0. [inputs]: Use LIBGCRYPT instead of LIBGCRYPT-1.5.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 2e74fbda43..61ab96adee 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -176,15 +176,17 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.7.2")
+ (version "0.8.0")
(source (origin
+ ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
+ ;; exists, but the server appears to be too slow and unreliable.
(method git-fetch)
(uri (git-reference
(url "https://github.com/artyom-poptsov/libguile-ssh.git")
(commit (string-append "v" version))))
(sha256
(base32
- "1wcv10xv7ayrhrg77zyng6flknnlkzhni24nf8x9nic00zha8znk"))))
+ "1ld2khzylaylhqfsfcvbxs95frvm8pkr7dq40ia1wwn9c349fcdv"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after
@@ -223,7 +225,7 @@ Additionally, various channel-specific options can be negotiated.")
("which" ,which)))
(inputs `(("guile" ,guile-2.0)
("libssh" ,libssh)
- ("libgcrypt" ,libgcrypt-1.5)))
+ ("libgcrypt" ,libgcrypt)))
(synopsis "Guile bindings to libssh")
(description
"Guile-SSH is a library that provides access to the SSH protocol for