summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-11 01:58:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-11 14:12:53 +0200
commitf6b7ccc9f9e72c6492c7be37ff7da769081dc2cc (patch)
tree04ddcb4db2cc50039e91d321962c4d6fed0549e5 /gnu/packages/spice.scm
parent41a659d2ecb95c80cbf29f5b0c5d78381550fbca (diff)
downloadpatches-f6b7ccc9f9e72c6492c7be37ff7da769081dc2cc.tar
patches-f6b7ccc9f9e72c6492c7be37ff7da769081dc2cc.tar.gz
gnu: spice: Update to 0.14.1 [fixes CVE-2018-10873].
* gnu/packages/spice.scm (spice): Update to 0.14.1. [source](uri): Update to new "spice-server" subdirectory. [native-inputs]: Add GLIB-NETWORKING and GSETTINGS-DESKTOP-SCHEMAS. [arguments]: Remove configure-flag which is now off even when celt is available. Add phase to set $SSL_CERT_FILE.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fc08a1dfdf..e708d726bb 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -177,15 +177,15 @@ which allows users to view a desktop computing environment.")
(define-public spice
(package
(name "spice")
- (version "0.14.0")
+ (version "0.14.1")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.spice-space.org/download/releases/"
- "spice-" version ".tar.bz2"))
+ "spice-server/spice-" version ".tar.bz2"))
(sha256
(base32
- "0j5q7cp5p95jk8fp48gz76rz96lifimdsx1wnpmfal0nnnar9nrs"))))
+ "068mb9l7wzk4k4c65bzvpw5fyyzh81rb6z81skgdxvh67pk5vb8y"))))
(build-system gnu-build-system)
(propagated-inputs
`(("openssl" ,openssl)
@@ -202,12 +202,18 @@ which allows users to view a desktop computing environment.")
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python)
- ("spice-gtk" ,spice-gtk)))
+ ("spice-gtk" ,spice-gtk)
+
+ ;; These are needed for the server listen tests.
+ ("glib-networking" ,glib-networking)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(arguments
`(#:configure-flags
- '("--disable-celt051" ; Disable support for unpackaged audio codec
- "--enable-lz4"
- "--enable-automated-tests")))
+ '("--enable-lz4"
+ "--enable-automated-tests")
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'use-empty-ssl-cert-file
+ (lambda _ (setenv "SSL_CERT_FILE" "/dev/null") #t)))))
(synopsis "Server implementation of the SPICE protocol")
(description "SPICE is a remote display system built for virtual
environments which allows you to view a computing 'desktop' environment