summaryrefslogtreecommitdiff
path: root/gnu/packages/skarnet.scm
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2016-07-31 10:40:08 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-01 01:11:57 +0200
commitcf04df0701cb85bb2b8b259cecb64ce67911c808 (patch)
tree6aacc67afe118498e4cb56bb419508e8272d082e /gnu/packages/skarnet.scm
parent915db95f67aecd4390fedfa31a0e01cf3805744d (diff)
downloadpatches-cf04df0701cb85bb2b8b259cecb64ce67911c808.tar
patches-cf04df0701cb85bb2b8b259cecb64ce67911c808.tar.gz
gnu: Add s6-linux-utils.
* gnu/packages/skarnet.scm (s6-linux-utils): New variable. Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/skarnet.scm')
-rw-r--r--gnu/packages/skarnet.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 7486c239d7..37e09d8642 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -279,3 +279,35 @@ environment.")))
performing well-known tasks such as @command{cut} and @command{grep}, but
optimized for simplicity and small size. They were designed for embedded
systems and other constrained environments, but they work everywhere.")))
+
+(define-public s6-linux-utils
+ (package
+ (name "s6-linux-utils")
+ (version "2.1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://skarnet.org/software/s6-linux-utils/s6-linux-utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bby751blynb7p8wd3npjm71lf10ysmfvqrd3dqrhhajpa2bl8rm"))))
+ (build-system gnu-build-system)
+ (inputs `(("skalibs" ,skalibs)))
+ (arguments
+ '(#:configure-flags (list
+ (string-append "--with-lib="
+ (assoc-ref %build-inputs "skalibs")
+ "/lib/skalibs")
+ (string-append "--with-sysdeps="
+ (assoc-ref %build-inputs "skalibs")
+ "/lib/skalibs/sysdeps"))
+ #:tests? #f))
+ (home-page "http://skarnet.org/software/s6-linux-utils")
+ (license isc)
+ (synopsis "Set of minimalistic Linux-specific system utilities")
+ (description
+ "s6-linux-utils is a set of minimalistic Linux-specific system utilities,
+such as @command{mount}, @command{umount}, and @command{chroot} commands,
+Linux uevent listeners, a @command{devd} device hotplug daemon, and more.")))