summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-11-12 16:00:39 +0000
committerLudovic Courtès <ludo@gnu.org>2018-11-14 21:34:09 +0100
commit6b7f1f8afa996e8882d2ca9145d39bbabf85c160 (patch)
treed5b82068a54e89a09ce3141a3c0fc97a5d15fe34 /gnu/packages/simulation.scm
parent0fc499834f7357a8bb76cca06b8979c67961b316 (diff)
downloadpatches-6b7f1f8afa996e8882d2ca9145d39bbabf85c160.tar
patches-6b7f1f8afa996e8882d2ca9145d39bbabf85c160.tar.gz
gnu: Add python-fenics-ffc.
* gnu/packages/simulation.scm (python-fenics-ffc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index ecdb2b2020..d1a5e46264 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -349,3 +349,55 @@ versions will also support Hermite and nonconforming elements.
FIAT is part of the FEniCS Project.")
(license license:lgpl3+)))
+
+(define-public python-fenics-ffc
+ (package
+ (name "python-fenics-ffc")
+ (version "2018.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fenics-ffc" version))
+ (sha256
+ (base32
+ "1b2ia5vlkw298x7rf0k2p3ihlpwkwgc98p3s6sbpds3hqmfrzdz9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-fenics-dijitso" ,python-fenics-dijitso)
+ ("python-fenics-fiat" ,python-fenics-fiat)
+ ("python-fenics-ufl" ,python-fenics-ufl)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":" (getenv "PYTHONPATH")))
+ (with-directory-excursion "test"
+ ;; FIXME: the tests in subdirectory
+ ;; 'unit/ufc/finite_element' require the ffc_factory
+ ;; extension module. This module, located in the 'libs'
+ ;; subdirectory, needs to be built and made accessible
+ ;; prior to running the tests.
+ (invoke "py.test" "unit/" "--ignore=unit/ufc/")
+ (with-directory-excursion "uflacs"
+ (invoke "py.test" "unit/")))
+ #t)))))
+ (home-page "https://bitbucket.org/fenics-project/ffc/")
+ (synopsis "Compiler for finite element variational forms")
+ (description "The FEniCS Form Compiler (FFC) is a compiler for
+finite element variational forms. From a high-level description of
+the form, it generates efficient low-level C++ code that can be used
+to assemble the corresponding discrete operator (tensor). In
+particular, a bilinear form may be assembled into a matrix and a
+linear form may be assembled into a vector. FFC may be used either
+from the command line (by invoking the @code{ffc} command) or as a
+Python module (@code{import ffc}).
+
+FFC is part of the FEniCS Project.")
+ ;; There are two files released with a public domain licence;
+ ;; ufc.h and ufc_geometry.h, in subdirectory 'ffc/backends/ufc'.
+ (license (list license:public-domain license:lgpl3+))))