summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-09-29 12:39:42 -0400
committerLeo Famulari <leo@famulari.name>2016-09-29 17:13:05 -0400
commitcfb7e269e9d91598d884b3d531710d7f22c11a44 (patch)
treec3dcca34f7a52225a38ac18e339c433d24d8bbc7 /gnu/packages/shells.scm
parent86d8f6d3efb8300a3354735cbf06be6c01e23243 (diff)
downloadpatches-cfb7e269e9d91598d884b3d531710d7f22c11a44.tar
patches-cfb7e269e9d91598d884b3d531710d7f22c11a44.tar.gz
gnu: xonsh: Remove bundled PLY.
* gnu/packages/shells.scm (xonsh)[source]: Add snippet to remove bundled python-ply. [inputs]: Add python-ply. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c165f99d4c..272fff7430 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -281,8 +281,18 @@ ksh, and tcsh.")
(uri (pypi-uri "xonsh" version))
(sha256
(base32
- "0byxd9kjl99q2pyvjh9jy18l0di1i35wr0qqgnw4i6jh6ig3zcki"))))
+ "0byxd9kjl99q2pyvjh9jy18l0di1i35wr0qqgnw4i6jh6ig3zcki"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ ;; Delete bundled ply.
+ (delete-file-recursively "xonsh/ply")
+ (substitute* '("setup.py")
+ (("'xonsh\\.ply',") ""))
+ #t))))
(build-system python-build-system)
+ (inputs
+ `(("python-ply" ,python-ply)))
(home-page "http://xon.sh/")
(synopsis "Python-ish shell")
(description