summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2016-12-22 22:42:04 +0100
committerKei Kebreau <kei@openmailbox.org>2016-12-22 17:59:41 -0500
commit572ee05c3134cf9408ba463c97fdbacb9a98f714 (patch)
treee7eb2ca65d87e911b6a029dbdbebfd903250f953 /gnu/packages/shells.scm
parent059b3aa9c335041d947cf2b765ab3dab811cfdc5 (diff)
downloadpatches-572ee05c3134cf9408ba463c97fdbacb9a98f714.tar
patches-572ee05c3134cf9408ba463c97fdbacb9a98f714.tar.gz
gnu: xonsh: Update to 0.5.0.
* gnu/packages/shells.scm (xonsh): Update to 0.5.0. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 1931609753..5fbac7437a 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -298,21 +299,21 @@ ksh, and tcsh.")
(define-public xonsh
(package
(name "xonsh")
- (version "0.4.7")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xonsh" version))
(sha256
(base32
- "04b0z41mxiwsp5rl21fzrixcdmx2kndjlh4gn3582qfga9hihf20"))
+ "1iml0mrjl2j3dsan5app6am77bd59s855p6yy6505ljdh552mv01"))
(modules '((guix build utils)))
(snippet
`(begin
;; Delete bundled ply.
(delete-file-recursively "xonsh/ply")
(substitute* '("setup.py")
- (("'xonsh\\.ply',") ""))
+ (("'xonsh\\.ply\\.ply',") ""))
#t))))
(build-system python-build-system)
(arguments