summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-24 05:54:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-24 21:34:20 +0200
commitf437e39aa2cd9214b03d5cf4f5bda22441834e04 (patch)
treed979c82b100ccc077b9ab21ed5922024ec6f36b3 /gnu/packages/shells.scm
parentc1144c78ad853dc1bfbd6f32a69fa0d53a79ff11 (diff)
downloadpatches-f437e39aa2cd9214b03d5cf4f5bda22441834e04.tar
patches-f437e39aa2cd9214b03d5cf4f5bda22441834e04.tar.gz
gnu: loksh: Use PREFIX.
* gnu/packages/shells.scm (loksh)[argumentss]: Substitute PREFIX for DESTDIR #:make-flags.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 47efe5db1b..3e9d797e2c 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -586,14 +586,13 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(#:tests? #f ;No tests included
+ `(#:tests? #f ; no tests included
#:make-flags (list "CC=gcc" "HAVE_LIBBSD=1"
- (string-append "DESTDIR="
- (assoc-ref %outputs "out"))
- "PREFIX=")
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ;No configure script
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/dimkr/loksh")
(synopsis "Korn Shell from OpenBSD")
(description