summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 03:59:38 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 05:02:14 -0400
commitc22f655fc80cd0765a06bc124a750344c07fb595 (patch)
tree4fccb87ae9d8f4dd312aa0beff5367eec7c59c4d /gnu/packages/shells.scm
parent607f050bec1839499a674e0522ce5f60f73076f7 (diff)
downloadpatches-c22f655fc80cd0765a06bc124a750344c07fb595.tar
patches-c22f655fc80cd0765a06bc124a750344c07fb595.tar.gz
gnu: tcsh: Use invoke instead of system*.
* gnu/packages/shells.scm (tcsh)[arguments]: Use invoke.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 685f6d2df4..526fdd1d35 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -264,7 +264,7 @@ written by Paul Haahr and Byron Rakitzis.")
(substitute* "tests/syntax.at"
(("; other_script.csh") "; /bin/sh other_script.csh"))
;; Now, let's generate the test suite and patch it
- (system* "make" "tests/testsuite")
+ (invoke "make" "tests/testsuite")
;; This file is ISO-8859-1 encoded.
(with-fluids ((%default-port-encoding #f))