summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-17 15:44:04 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:50 -0400
commit04953dca414788433f039e1844a6cc1c8f37be5f (patch)
treef9c84325bcb2a6eeffbd271402a84f904c291af9 /gnu/packages/serialization.scm
parentbb3062ad6290223ea24144ca8aa1f4cddac8f9be (diff)
downloadpatches-04953dca414788433f039e1844a6cc1c8f37be5f.tar
patches-04953dca414788433f039e1844a6cc1c8f37be5f.tar.gz
gnu: Add flatbuffers.
* gnu/packages/serialization.scm (flatbuffers): New variable.
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 9bbac3ac22..fd61462776 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -411,3 +412,28 @@ JSON's ability, but serializes to a binary format which is smaller and faster
to generate and parse. The two primary functions are @code{cbor.loads} and
@code{cbor.dumps}.")
(license license:asl2.0)))
+
+(define-public flatbuffers
+ (package
+ (name "flatbuffers")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/flatbuffers/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0blc978wc5h91662vai24xj92c3bx56y6hzid90qva7il302jl64"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out") "/lib")
+ "-DCMAKE_BUILD_TYPE=Release")))
+ (home-page "https://google.github.io/flatbuffers/")
+ (synopsis "Memory-efficient serialization library")
+ (description "FlatBuffers is a cross platform serialization library for C++,
+C#, C, Go, Java, JavaScript, PHP, and Python. It was originally created for
+game development and other performance-critical applications.")
+ (license license:asl2.0)))