summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-05-17 18:38:22 -0500
committerEric Bavier <bavier@member.fsf.org>2016-09-09 00:45:14 -0500
commitb9b3440b1f326eea441360253c8b767eb4c129b7 (patch)
tree20ccbbb961cc84ac4ba38f95be0b25a2015570cd /gnu/packages/search.scm
parente0479f522390d5952d9547f71c33afe9f9c30403 (diff)
downloadpatches-b9b3440b1f326eea441360253c8b767eb4c129b7.tar
patches-b9b3440b1f326eea441360253c8b767eb4c129b7.tar.gz
gnu: Add mlocate.
* gnu/packages/search.scm (mlocate): New variable.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 9b01909753..9a7bc76463 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,7 +19,7 @@
(define-module (gnu packages search)
#:use-module ((guix licenses)
- #:select (gpl2+ gpl3+ bsd-3 x11))
+ #:select (gpl2 gpl2+ gpl3+ bsd-3 x11))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -148,4 +148,27 @@ accounting for new lines and paragraph changes. It also has robust support
for parsing HTML files.")
(license gpl3+)))
+(define-public mlocate
+ (package
+ (name "mlocate")
+ (version "0.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://fedorahosted.org/releases/m/l/"
+ "mlocate/mlocate-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0gi6y52gkakhhlnzy0p6izc36nqhyfx5830qirhvk3qrzrwxyqrh"))))
+ (build-system gnu-build-system)
+ (home-page "https://fedorahosted.org/mlocate/")
+ (synopsis "Locate files on the filesystem")
+ (description
+ "mlocate is a locate/updatedb implementation. The 'm' stands for
+\"merging\": @code{updatedb} reuses the existing database to avoid rereading
+most of the file system, which makes it faster and does not trash the system
+caches as much. The locate(1) utility is intended to be completely compatible
+with slocate, and attempts to be compatible to GNU locate when it does not
+conflict with slocate compatibility.")
+ (license gpl2)))
+
;;; search.scm ends here