summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-01-27 22:00:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-01-27 22:00:39 +0100
commitc3753f380397eb0ad2fd2596747d7996e03cbecc (patch)
tree794a0b6b35bcdb393d23468eeda46dae89cbe2bb /gnu/packages/search.scm
parent7afd2069d5995b5642b5de971f0aafdba966a784 (diff)
downloadpatches-c3753f380397eb0ad2fd2596747d7996e03cbecc.tar
patches-c3753f380397eb0ad2fd2596747d7996e03cbecc.tar.gz
gnu: python-xapian-bindings: Don't hard-code Python sitedir.
* gnu/packages/search.scm (python-xapian-bindings)[arguments]: In #:make-flags, use VERSION-MAJOR+MINOR to set pkgpylibdir.
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 1986b07217..1479d1bbbb 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -24,6 +24,7 @@
#:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11))
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
@@ -90,7 +91,9 @@ rich set of boolean query operators.")
#:make-flags
(list (string-append "pkgpylibdir="
(assoc-ref %outputs "out")
- "/lib/python3.5/site-packages/xapian"))))
+ "/lib/python" ,(version-major+minor
+ (package-version python))
+ "/site-packages/xapian"))))
(inputs
`(("python" ,python)
("python-sphinx" ,python-sphinx) ; for documentation