summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-01 16:25:59 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-01 20:08:38 +0100
commitabfc114ae53ad059546ffe95a8c919c2d675af11 (patch)
tree6bfa70ed0cae9dae05980095a124411fa090e7b3 /gnu/packages/sdl.scm
parent70c8b1ec300f3fe9144837988cabd83f91287cab (diff)
downloadpatches-abfc114ae53ad059546ffe95a8c919c2d675af11.tar
patches-abfc114ae53ad059546ffe95a8c919c2d675af11.tar.gz
gnu: sdl2: Add KMSDRM video backend.
* gnu/packages/sdl.scm (sdl2): Add KMSDRM video backend.
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 2e125c9d23..d548db89cf 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2017 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
@@ -115,7 +115,8 @@ joystick, and graphics hardware.")
(arguments
(substitute-keyword-arguments (package-arguments sdl)
((#:configure-flags flags)
- `(append '("--disable-wayland-shared")
+ `(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
+ "--disable-kmsdrm-shared")
,flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems