summaryrefslogtreecommitdiff
path: root/gnu/packages/scsi.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 19:15:17 +0100
commit99f63f011df2aab38e98d7ee4608a8c70bf74c4d (patch)
tree3f224028f30c60f2ed7b9846365ad926192fc7e9 /gnu/packages/scsi.scm
parente9a8b603337802a77ff2d68f0d30dc0e67721e3a (diff)
parent4f03aa23e805bd653de774e1d74ed2f50826899b (diff)
downloadpatches-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar
patches-99f63f011df2aab38e98d7ee4608a8c70bf74c4d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/scsi.scm')
-rw-r--r--gnu/packages/scsi.scm43
1 files changed, 28 insertions, 15 deletions
diff --git a/gnu/packages/scsi.scm b/gnu/packages/scsi.scm
index 92e2d7af4c..f8c5d5ef60 100644
--- a/gnu/packages/scsi.scm
+++ b/gnu/packages/scsi.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,7 +19,7 @@
(define-module (gnu packages scsi)
#:use-module ((guix licenses)
- #:select (gpl2+ bsd-3))
+ #:select (gpl2+ bsd-2 bsd-3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -26,29 +27,41 @@
(define-public sg3-utils
(package
(name "sg3-utils")
- (version "1.42")
+ (version "1.44")
(source (origin
(method url-fetch)
(uri (string-append "http://sg.danny.cz/sg/p/sg3_utils-"
version ".tar.xz"))
(sha256
(base32
- "1fg71rj0f1gdjmkj0z8wlv46cf9lryjdyjkbi7fjmssgi5jyvblp"))))
+ "01avlgrbxlij8spish4i69ji1m49biz4mbayzzc2qx0hcl8ar56a"))))
(build-system gnu-build-system)
(home-page "http://sg.danny.cz/sg/sg3_utils.html")
(synopsis "SCSI device utilities")
(description
"sg3-utils is a collection of utilities for devices that use the Small
-Computer System Interface (SCSI) command set. It includes utilities to read
-data from, write data to, control, modify, and query the state of SCSI
-devices. For example, this package provides command-line tools to copy data
-based on @code{dd} syntax and semantics (called @code{sg_dd}, @code{sgp_dd}
-and @code{sgm_dd}), check INQUIRY data and VPD pages (@code{sg_inq}), check
-mode and log pages (@code{sginfo}, @code{sg_modes} and @code{sg_logs}), spin
-up and down disks (@code{sg_start}), do self tests (@code{sg_senddiag}), parse
-sense data (@code{sg_decode_sense}), and perform various other functions. In
-addition, this package includes a library, called libsgutils, which can be
+Computer System Interface (@dfn{SCSI}) command set. It includes utilities to
+read data from, write data to, control, modify, and query the state of SCSI
+devices.
+
+For example, this package provides command-line tools to:
+@itemize
+@item copy data based on @code{dd} syntax and semantics (called @command{sg_dd},
+@command{sgp_dd}, and @command{sgm_dd})
+@item check @code{INQUIRY} data and @code{VPD pages} (@command{sg_inq})
+@item check mode and log pages (@command{sginfo}, @command{sg_modes}, and
+@command{sg_logs})
+@item spin up and down disks (@command{sg_start})
+@item do self-tests (@code{sg_senddiag})
+@item parse sense data (@code{sg_decode_sense})
+@item and perform various other functions.
+@end itemize
+
+In addition, this package includes a library, called libsgutils, which can be
used in C and C++ programs to interact with SCSI devices.")
- ;; The libsgutils library itself is licensed under bsd-3. Some tools are
- ;; licensed under bsd-3, also. Some tools are licensed under gpl2+.
- (license (list gpl2+ bsd-3))))
+ ;; See README: "All utilities and libraries have either a "2 clause" BSD
+ ;; license or are "GPL-2ed". [...] That BSD license was updated from the
+ ;; "3 clause" to the newer "2 clause" version on 20180119. To save space
+ ;; various source code files refer to a file called "BSD_LICENSE" [...]."
+ ;; Some files (like sg_compare_and_write.c) retain their 3-clause headers!
+ (license (list gpl2+ bsd-2 bsd-3))))