summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-07-19 21:26:42 +0800
committer宋文武 <iyzsong@gmail.com>2016-07-22 19:09:20 +0800
commit782170c4f56a43c8bcdd9cffe0bb489e918211a6 (patch)
tree0610f4d06a8e51b5e9e572a0d839f286a222b401 /gnu/packages/scheme.scm
parente8c6811bf1ccada01f99598ba4925b30e0935987 (diff)
downloadpatches-782170c4f56a43c8bcdd9cffe0bb489e918211a6.tar
patches-782170c4f56a43c8bcdd9cffe0bb489e918211a6.tar.gz
gnu: racket: Add more inputs.
* gnu/packages/scheme.scm (racket)[inputs]: Add glu, gmp, libpng, libx11, mesa, mpfr, openssl and unixodbc. Replace libjpeg-8 with libjpeg and gtk+-2 with gtk+.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 8d3ca33413..e4cd72a7b6 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -23,7 +23,7 @@
(define-module (gnu packages scheme)
#:use-module (gnu packages)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:hide (openssl))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -48,6 +48,8 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages image)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages gl)
#:use-module (ice-9 match))
(define (mit-scheme-source-directory system version)
@@ -477,15 +479,25 @@ implementation techniques and as an expository tool.")
%standard-phases))
#:tests? #f ; XXX: how to run them?
))
- (inputs `(("libffi" ,libffi)
- ("glib" ,glib) ; for DrRacket
- ("cairo" ,cairo)
- ("pango" ,pango)
- ("libjpeg" ,libjpeg-8)
- ("fontconfig" ,fontconfig)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("gtk" ,gtk+-2)
- ("sqlite" ,sqlite))) ;needed to build the doc
+ (inputs
+ `(("libffi" ,libffi)
+ ;; Hardcode dynamically loaded libraries for better functionality.
+ ;; sqlite and libraries for `racket/draw' are needed to build the doc.
+ ("cairo" ,cairo)
+ ("fontconfig" ,fontconfig)
+ ("glib" ,glib)
+ ("glu" ,glu)
+ ("gmp" ,gmp)
+ ("gtk+" ,gtk+) ; propagates gdk-pixbuf+svg
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libx11" ,libx11)
+ ("mesa" ,mesa)
+ ("mpfr" ,mpfr)
+ ("openssl" ,openssl)
+ ("pango" ,pango)
+ ("sqlite" ,sqlite)
+ ("unixodbc" ,unixodbc)))
(home-page "http://racket-lang.org")
(synopsis "Implementation of Scheme and related languages")
(description