summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-30 14:18:34 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-30 14:18:51 +0200
commitffc1074f86be782035a2162c60515c0a9db999ca (patch)
tree0c2bc348504b9f5bddc40ccfcc036a7f9a0a5157 /gnu/packages/scheme.scm
parent46cb9da28597039a7d158ce4b8e0bcacf7700fe3 (diff)
downloadpatches-ffc1074f86be782035a2162c60515c0a9db999ca.tar
patches-ffc1074f86be782035a2162c60515c0a9db999ca.tar.gz
gnu: hop: Allow compilation with Bigloo 4.0b.
Fixes <http://bugs.gnu.org/15194>. Reported by Mark H Weaver <mhw@netris.org>. * gnu/packages/patches/hop-bigloo-4.0b.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/scheme.scm (hop): Use it.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index eb339d7236..43853fa08c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -251,6 +251,7 @@ between Scheme and C# programs.")
"\\.so$")))))
%standard-phases))
#:tests? #f ; no test suite
+ #:patches (list (assoc-ref %build-inputs "patch/bigloo-4.0b"))
#:modules ((guix build gnu-build-system)
(guix build utils)
(ice-9 popen)
@@ -259,7 +260,10 @@ between Scheme and C# programs.")
(srfi srfi-1))))
(inputs `(("bigloo" ,bigloo)
("which" ,which)
- ("patchelf" ,patchelf)))
+ ("patchelf" ,patchelf)
+
+ ("patch/bigloo-4.0b"
+ ,(search-patch "hop-bigloo-4.0b.patch"))))
(home-page "http://hop.inria.fr/")
(synopsis "A multi-tier programming language for the Web 2.0")
(description