summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-01-27 20:48:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-02-01 15:53:32 +0100
commit58f91e4d03e102058fc0f8a859cb144c40c6a1d0 (patch)
tree5fb56be8fcd7128c499bd7be82a526727d4acfc9 /gnu/packages/scheme.scm
parent61ac75445320890e9be38dc04492cae3caf657a2 (diff)
downloadpatches-58f91e4d03e102058fc0f8a859cb144c40c6a1d0.tar
patches-58f91e4d03e102058fc0f8a859cb144c40c6a1d0.tar.gz
download: url-fetch/tarball: Make ‘name’ truly optional.
* guix/download.scm (url-fetch/tarbomb): Fall back to ‘file-name’ if ‘name’ is #f, like the regular ‘url-fetch’ does. * gnu/packages/bioinformatics.scm (muscle)[source]: Remove ‘file-name’. * gnu/packages/engineering.scm (fastcap)[source]: Likewise. * gnu/packages/scheme.scm (scmutils)[source]: Likewise.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm1
1 files changed, 0 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 2756805f3d..1210ab526b 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -604,7 +604,6 @@ threads.")
(snippet
;; Remove binary code
'(delete-file-recursively "scmutils/mit-scheme"))
- (file-name (string-append name "-" version ".tar.gz"))
(uri (string-append "http://groups.csail.mit.edu/mac/users/gjs/6946"
"/scmutils-tarballs/" name "-" version
"-x86-64-gnu-linux.tar.gz"))