summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-12 11:12:38 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2018-08-12 20:20:36 -0400
commite3fc9bcce2cfc26a60747c58f5c8c59cc8400785 (patch)
treeaf69756b22e755e8748583686ea6ff7b2285c7a5 /gnu/packages/scheme.scm
parent5a0696b2e35e09e6fe21db3df6a8005f3c953896 (diff)
downloadpatches-e3fc9bcce2cfc26a60747c58f5c8c59cc8400785.tar
patches-e3fc9bcce2cfc26a60747c58f5c8c59cc8400785.tar.gz
gnu: racket: Ignore bytecode checksums in the store.
Fixes <https://debbugs.gnu.org/30680>. * gnu/packages/patches/racket-store-checksum-override.patch: New file. * gnu/packages/scheme.scm (racket)[sources]: Add it.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 4178a45a89..b30245ccea 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -421,7 +421,8 @@ implementation techniques and as an expository tool.")
(patches (search-patches
;; See: https://github.com/racket/racket/issues/1962
;; This can be removed in whatever Racket release comes after 6.12
- "racket-fix-xform-issue.patch"))))
+ "racket-fix-xform-issue.patch"
+ "racket-store-checksum-override.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases