summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-20 13:37:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-20 13:37:58 +0200
commit2817ac3c18c1b1a6291c052bc61edd0947890a82 (patch)
tree9985705b35274ae1d6655be789346a98beff63de /gnu/packages/scheme.scm
parentecd13016517f0113016fef090782b725fd5e80ce (diff)
parent3e12df7d71547b4eca718b6b0e1fc244722dcc39 (diff)
downloadpatches-2817ac3c18c1b1a6291c052bc61edd0947890a82.tar
patches-2817ac3c18c1b1a6291c052bc61edd0947890a82.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 2e46a8453f..9654fe36f5 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -532,7 +532,7 @@ of libraries.")
(define-public gambit-c
(package
(name "gambit-c")
- (version "4.8.9")
+ (version "4.9.0")
(source
(origin
(method url-fetch)
@@ -542,25 +542,14 @@ of libraries.")
(string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
".tgz"))
(sha256
- (base32 "16sg1s8myzxqpimj5ry6lfza0qfs157zj28bvmxwwgy89jd9m5v7"))))
+ (base32 "19862w9ij0g5xrkskl4g89xbs17gp9cc6cfcdca6dlfkb3lk6xhp"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
;; According to the ./configure script, this makes the build slower and
;; use >= 1 GB memory, but makes Gambit much faster.
- '("--enable-single-host")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda _
- (substitute* '("tests/makefile")
- ;; '-:' is how run-time options are set. 'tl' sets some terminal
- ;; option, which makes it fail in our build environment. It
- ;; recommends using 'd-' as a solution, which sets the REPL
- ;; interaction channel to stdin/stdout.
- (("gsi -:tl") "gsi -:d-,tl"))
- #t)))))
- (home-page "http://www.iro.umontreal.ca/~gambit/")
+ '("--enable-single-host")))
+ (home-page "http://gambitscheme.org")
(synopsis "Efficient Scheme interpreter and compiler")
(description
"Gambit consists of two main programs: gsi, the Gambit Scheme