summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-15 00:33:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-15 14:31:22 +0100
commit3e8867196c581d8bf8dd6c92a91954ef058bae93 (patch)
treec2b635e4a967b05a200c6bb3d5a76e1f4cfc5b85 /gnu/packages/scheme.scm
parent91815e8dc205d2a24511b1d3644a1e2fd8d73153 (diff)
downloadpatches-3e8867196c581d8bf8dd6c92a91954ef058bae93.tar
patches-3e8867196c581d8bf8dd6c92a91954ef058bae93.tar.gz
gnu: gauche: Update to 0.9.9.
* gnu/packages/scheme.scm (gauche): Update to 0.9.9.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a320cbf831..b0da2ac36b 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1001,7 +1001,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
(define-public gauche
(package
(name "gauche")
- (version "0.9.7")
+ (version "0.9.9")
(home-page "http://practical-scheme.net/gauche/index.html")
(source
(origin
@@ -1010,11 +1010,10 @@ The core is 12 builtin special forms and 33 builtin functions.")
"mirror://sourceforge/gauche/Gauche/Gauche-"
version ".tgz"))
(sha256
- (base32
- "181nycikma0rwrb1h6mi3kys11f8628pq8g5r3fg5hiz5sabscrd"))
+ (base32 "1yzpszhw52vkpr65r5d4khf3489mnnvnw58dd2wsvvx7499k5aac"))
(modules '((guix build utils)))
(snippet '(begin
- ;; Remove libatomic-ops
+ ;; Remove libatomic-ops.
(delete-file-recursively "gc/libatomic_ops")
#t))))
(build-system gnu-build-system)
@@ -1023,13 +1022,13 @@ The core is 12 builtin special forms and 33 builtin functions.")
("zlib" ,zlib)))
(native-inputs
`(("texinfo" ,texinfo)
- ("openssl" ,openssl) ; needed for tests
- ("pkg-config" ,pkg-config))) ; needed to find external libatomic-ops
+ ("openssl" ,openssl) ; needed for tests
+ ("pkg-config" ,pkg-config))) ; needed to find external libatomic-ops
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh
- ;; needed only for tests
+ ;; Needed only for tests.
(lambda _
(substitute* '("configure"
"test/www.scm"
@@ -1046,14 +1045,14 @@ The core is 12 builtin special forms and 33 builtin functions.")
(invoke "make" "info"))
#t))
(add-before 'check 'patch-normalize-test
- ;; neutralize sys-normalize-pathname test as it relies on
- ;; the home directory; (setenv "HOME" xx) isn't enough)
+ ;; Neutralize sys-normalize-pathname test as it relies on
+ ;; the home directory; (setenv "HOME" xx) isn't enough).
(lambda _
(substitute* "test/system.scm"
(("~/abc") "//abc"))
#t))
(add-before 'check 'patch-network-tests
- ;; remove net checks
+ ;; Remove net checks.
(lambda _
(substitute* "ext/Makefile"
(("binary net termios") "binary termios"))