summaryrefslogtreecommitdiff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-24 18:02:27 -0400
committerLeo Famulari <leo@famulari.name>2017-05-24 18:02:27 -0400
commit38f1163c955945e92ba4d48c6f7c233c7a2aac1f (patch)
tree19c19ef24df71475d89b648fd3a34dacfe78fdcb /gnu/packages/scanner.scm
parent9269ce492576a9fbb5aa39548f03dab9207fb8e9 (diff)
parentff51a87cae360334ed42c79c3e4e46fb7c121eb2 (diff)
downloadpatches-38f1163c955945e92ba4d48c6f7c233c7a2aac1f.tar
patches-38f1163c955945e92ba4d48c6f7c233c7a2aac1f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm51
1 files changed, 27 insertions, 24 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 7bdbf35f05..f44f037efb 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,15 +32,15 @@
(define-public sane-backends-minimal
(package
(name "sane-backends-minimal")
- (version "1.0.25")
+ (version "1.0.27")
(source (origin
(method url-fetch)
(uri (string-append
- "https://alioth.debian.org/frs/download.php/file/4146/"
+ "https://alioth.debian.org/frs/download.php/latestfile/176/"
"sane-backends-" version ".tar.gz"))
(sha256
(base32
- "0b3fvhrxl4l82bf3v0j47ypjv6a0k5lqbgknrq1agpmjca6vmmx4"))
+ "1j9nbqspaj0rlgalafb5z6r606k0i22kz0rcpd744p176yzlfdr9"))
(modules '((guix build utils)))
(snippet
;; Generated HTML files and udev rules normally embed a
@@ -53,32 +54,34 @@
(inputs
`(("libusb-compat" ,libusb-compat)))
(arguments
- `(#:tests? #f
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'configure 'disable-backends
(lambda _
(setenv "BACKENDS" " ")
#t))
- (add-after
- 'install 'install-udev-rules
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/lib/udev/rules.d"))
- (copy-file "tools/udev/libsane.rules"
- (string-append out
- "/lib/udev/rules.d/"
- "60-libsane.rules"))))))))
- ;; It would seem that tests are not maintained - fails with
- ;; the following:
- ;;
- ;; < This page was last updated on Wed Jul 31 07:52:48 2013
- ;; < by sane-desc 3.5 from sane-backends 1.0.24git
- ;; ---
- ;; > This page was last updated on Sun Oct 19 15:41:39 2014
- ;; > by sane-desc 3.5 from sane-backends 1.0.24
- ;; **** File generated for html-backends-split mode is different from reference
- ;; Makefile:501: recipe for target 'check.local' failed
+ ;; Disable unmaintained tests that that fail with errors resembling:
+ ;;
+ ;; < # by sane-desc 3.5 from sane-backends 1.0.24git on Jul 31 2013
+ ;; ---
+ ;; > # by sane-desc 3.5 from sane-backends 1.0.27 on 1970-01-01#
+ ;; FAIL: sane-desc -m usermap -s ./data
+ (add-before 'configure 'disable-failing-tests
+ (lambda _
+ (for-each
+ (lambda (pattern)
+ (substitute* "testsuite/tools/Makefile.in"
+ (((string-append " " pattern " ")) " ")))
+ (list "usermap" "db" "udev" "udev\\+acl" "udev\\+hwdb" "hwdb"))
+ #t))
+ (add-after 'install 'install-udev-rules
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/lib/udev/rules.d"))
+ (copy-file "tools/udev/libsane.rules"
+ (string-append out
+ "/lib/udev/rules.d/"
+ "60-libsane.rules"))))))))
(home-page "http://www.sane-project.org")
(synopsis
"Raster image scanner library and drivers, without scanner support")