summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@member.fsf.org>2014-04-06 12:25:57 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-06-23 08:05:00 -0400
commit1790739c756e69e6879419b2d15bc027877b2ac3 (patch)
tree410bab0616de3cd107b04f4dd337d563f595704b /gnu/packages/samba.scm
parentb76a3847158721770a3012f92a64c107cb237644 (diff)
downloadpatches-1790739c756e69e6879419b2d15bc027877b2ac3.tar
patches-1790739c756e69e6879419b2d15bc027877b2ac3.tar.gz
gnu: Add talloc.
* gnu/packages/samba.scm (talloc): New variable.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 5b52a38e4a..c6fef6154d 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -162,3 +162,35 @@ DOS and Windows, OS/2, GNU/Linux and many others.
Samba is an important component to seamlessly integrate Linux/Unix Servers and
Desktops into Active Directory environments using the winbind daemon.")
(license gpl3+)))
+
+(define-public talloc
+ (package
+ (name "talloc")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.samba.org/ftp/talloc/talloc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13zh628hzlp2v9vj70knnfac2xbxqrdhgap30csq4zv4h8w3j087"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; talloc uses a custom configuration script that runs a
+ ;; python script called 'waf'.
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))
+ %standard-phases)))
+ (inputs
+ `(("python" ,python-2)))
+ (home-page "http://talloc.samba.org")
+ (synopsis "Hierarchical, reference counted memory pool system")
+ (description
+ "Talloc is a hierarchical, reference counted memory pool system with
+destructors. It is the core memory allocator used in Samba.")
+ (license gpl3+))) ;; The bundled "replace" library uses LGPL3.