summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-16 11:16:16 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-17 10:01:00 +0800
commitae916e02cbd4bd41b3f486d71f00f68b6fea4b7b (patch)
treedff06a2ff596c08ada2dc37d18e79c112b7b2694 /gnu/packages/samba.scm
parent4ca02340691624316330619fc6fec5a5e68e00b7 (diff)
downloadpatches-ae916e02cbd4bd41b3f486d71f00f68b6fea4b7b.tar
patches-ae916e02cbd4bd41b3f486d71f00f68b6fea4b7b.tar.gz
gnu: Add ppp.
* gnu/packages/samba.scm (ppp): New variable.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index d7223bc0ba..484eafb647 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -23,6 +23,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
#:use-module (gnu packages acl)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages popt)
#:use-module (gnu packages openldap)
#:use-module (gnu packages readline)
@@ -196,3 +197,42 @@ Desktops into Active Directory environments using the winbind daemon.")
"Talloc is a hierarchical, reference counted memory pool system with
destructors. It is the core memory allocator used in Samba.")
(license gpl3+))) ;; The bundled "replace" library uses LGPL3.
+
+(define-public ppp
+ (package
+ (name "ppp")
+ (version "2.4.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.samba.org/ftp/ppp/ppp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0c7vrjxl52pdwi4ckrvfjr08b31lfpgwf3pp0cqy76a77vfs7q02"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-Makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc"))
+ (libpcap (assoc-ref inputs "libpcap")))
+ (substitute* "pppd/Makefile.linux"
+ (("/usr/include/crypt\\.h")
+ (string-append libc "/include/crypt.h"))
+ (("/usr/include/pcap-bpf.h")
+ (string-append libpcap "/include/pcap-bpf.h")))))))))
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (synopsis "Implementation of the Point-to-Point Protocol")
+ (home-page "https://ppp.samba.org/")
+ (description
+ "The Point-to-Point Protocol (PPP) provides a standard way to establish
+a network connection over a serial link. At present, this package supports IP
+and IPV6 and the protocols layered above them, such as TCP and UDP.")
+ ;; pppd, pppstats and pppdump are under BSD-style notices.
+ ;; some of the pppd plugins are GPL'd.
+ ;; chat is public domain.
+ (license (list bsd-3 bsd-4 gpl2+ public-domain))))