summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
commitd1f3b333e6176a7879ab3742bbebb2a99f61a528 (patch)
tree8bd82ce68bd2534a48bf13c7256997f82dd1b3f4 /gnu/packages/rust.scm
parente01d384efcdaf564bbb221e43b81e087c8e2af06 (diff)
parent861907f01efb1cae7f260e8cb7b991d5034a486a (diff)
downloadpatches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar
patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm28
1 files changed, 21 insertions, 7 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 7f0e5e5cb6..241826ef82 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -379,7 +379,7 @@ test = { path = \"../libtest\" }
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison) ; For the tests
- ("cmake" ,cmake)
+ ("cmake" ,cmake-minimal)
("flex" ,flex) ; For the tests
("gdb" ,gdb) ; For the tests
("procps" ,procps) ; For the tests
@@ -391,7 +391,7 @@ test = { path = \"../libtest\" }
(inputs
`(("jemalloc" ,jemalloc-4.5.0)
("llvm" ,llvm-3.9.1)
- ("openssl" ,openssl)
+ ("openssl" ,openssl-1.0)
("libssh2" ,libssh2) ; For "cargo"
("libcurl" ,curl))) ; For "cargo"
@@ -400,10 +400,7 @@ test = { path = \"../libtest\" }
;; modules (see <https://bugs.gnu.org/31392>).
(native-search-paths
(list (search-path-specification
- (variable "C_INCLUDE_PATH")
- (files '("include")))
- (search-path-specification
- (variable "CPLUS_INCLUDE_PATH")
+ (variable "CPATH")
(files '("include")))
(search-path-specification
(variable "LIBRARY_PATH")
@@ -1057,7 +1054,7 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(("bins::check") "//bins::check"))
#t)))))))))
-(define-public rust
+(define-public rust-1.36
(let ((base-rust
(rust-bootstrapped-package rust-1.35 "1.36.0"
"06xv2p6zq03lidr0yaf029ii8wnjjqa894nkmrm6s0rx47by9i04")))
@@ -1068,3 +1065,20 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
((#:phases phases)
`(modify-phases ,phases
(delete 'patch-process-docs-rev-cmd))))))))
+
+(define-public rust
+ (let ((base-rust
+ (rust-bootstrapped-package rust-1.36 "1.37.0"
+ "1hrqprybhkhs6d9b5pjskfnc5z9v2l2gync7nb39qjb5s0h703hj")))
+ (package
+ (inherit base-rust)
+ (arguments
+ (substitute-keyword-arguments (package-arguments base-rust)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'configure 'configure-cargo-home
+ (lambda _
+ (let ((cargo-home (string-append (getcwd) "/.cargo")))
+ (mkdir-p cargo-home)
+ (setenv "CARGO_HOME" cargo-home)
+ #t))))))))))